Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2024 - 09:00 CEST
Scheduled
We will be performing maintenance on Tuesday 28/05/2024 between 09:00 CEST and 13:00 CEST. During this period the PhishBrain service will not be available in the EU region. As always if you have questions or issues please raise a support ticket.
Posted May 21, 2024 - 11:40 CEST
This scheduled maintenance affected: Services (Phishbrain).